View Single Post
  #1  
Old 10-Apr-2017, 01:48 PM
JamieMac JamieMac is offline
Registered Forum User
 
Posts: 1
Join Date: Nov 2010
2005 999R starting Issues

Hi, I was wondering if any of the genius's on the forum can help?

I'm slowly pulling my hair out over the past couple of days with various problems on a 2005 999R.
I'm helping out a mate who seems to keep all his bikes next to the Titanic judging by the state of them

He brought round a very dead 2005 999R. No electrical activity at all and mechanical needing major work. Mechanical stuff all easy. Electrical wise I've tried a new battery first, still dead. After cleaning up all the loom connectors, briefly got life and pretty much every error code possible. Error codes changing with every key on/off. So in went a new Main/Front loom and check/swapped out Relays. Old loom had been repaired in about 30 places by someone previously. Hideous mess. Cleaned up every accessory connector.

Now new loom in: Everything working except one "error code 37.3 Serial Cable Disconnect" and fuel pump not 'spinning up' on key 'on'. Funnily the fuel pump was the only thing working before loom change but made a horrible shrieking sound before blowing key on 7.5 amp fuse. Fuel pump spins up if connected directly to 12v supply. Switched 12v on loom connection to fuel flange when tested with multimeter.

The bike has a Nemesis ECU. Would the Nemesis show error 37.3 if the immobiliser had been de-activated? Or could the error 37.3 be stopping the fuel pump spinning up? Clocks show ignition key being recognised. Antenna working fine i.e no 37.1 code.

Was does error "error code 37.3 Serial Cable Disconnect" really mean?

Thanks in advance, Jamie
Reply With Quote