Ducati Sporting Club
Home Calendar Gallery Membership Online Shop DSC Blogs Extras
Go Back   Ducati Sporting Club > Model Specific - Discussion, Technical Problems and Help > STs
Reload this Page ST4s non start issue
Forum Home Register FAQ Search Forum Recent Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 20-May-2012, 12:11 PM
pguenet pguenet is offline
Registered Forum User
Big Twin
 
Posts: 1,411
Join Date: Aug 2002
ST4s non start issue

Hi

Posting this here as I don't seem to be able to fix myself.

My ST4s has decided to stop starting all of a sudden.

- Battery cranks the engine OK
- Sparks go to the plugs OK
- Fuel pump primes OK
- I have an alarm on it but have bypassed it using a replacement loom and problem remains

- I have tried resetting the immobiliser by turning on with Red Key - then turning on with each of the spare keys.

- I have not tried the side stand switch but have a side stand bypass anyway and can start on the side stand.

Problem happened all of a sudden, no sign of weakening at start or else.
Rode the bike to work in the morning with no problem whatsoever.
It decided not to start on the way back and got stranded.

It looks like the problem is that no fuel is spit by the injectors.
I have removed the airbox and looking into the throttle bodies and it is stone dry in there.

Any idea what could be the problem?
Do you know if the immobiliser cuts the injection?
Would I need to change the little black box on the side?
Do I need to change ECU as well?

Please let me know if you have any idea?

Cheers
philippe
Reply With Quote
  #2  
Old 21-May-2012, 02:58 PM
keith_mann1959's Avatar
keith_mann1959 keith_mann1959 is offline
Registered Forum User
Mille
Bikes: ST4S
 
Posts: 364
Join Date: Dec 2002
Mood: Finally gotten over the 748R getting stolen thing. Actually, no i haven't !
Not suffered it myself but i understand the internal tank fuel pipes can split when they are old.

This would mean that the pump is doing its job but the pressure is gone.

It might be worth trying to see if you can remove the fuel supply pipe from under the tank and determine whether the fuel is either not coming out under pressure or whether the injectors are not delivering what is supplied to them.
Reply With Quote
  #3  
Old 21-May-2012, 03:10 PM
pguenet pguenet is offline
Registered Forum User
Big Twin
 
Posts: 1,411
Join Date: Aug 2002
I think that I have identified the issue.

It was the immobiliser. I have redone the Red key sequence as I did not realise that there was some very specific sequence/timing to respect.

Looks like the bike is starting now.

Still puzzled how something would have reset itself and the bike stopped starting for some reason.

p
Reply With Quote
  #4  
Old 21-May-2012, 03:20 PM
antonye's Avatar
DSC Member antonye antonye is offline
Administrator
Webteam
MotoGP God
Bikes: 748S, HM1100S, DD-A
 
Posts: 12,695
Join Date: Feb 2002
Mood: Passion Killer
Interesting that you managed to reset it by reprogramming the keys.
It may be you ran down both the main battery and the internal backup battery in the immobiliser? I've never taken one of those style immobiliser boxes apart to see what's inside, so it would be interesting to see if there is a battery backup.


I'd rather die peacefully in my sleep like my Grandfather,
than screaming in terror like his passengers.- Jim Harkins

Ducati 748S | Ducati Hypermotard 1100S | 600-620SS DesmoDue Racebike #111 <-- Sold!! | Avanti Race Parts
Reply With Quote
  #5  
Old 15-Nov-2012, 10:40 AM
pguenet pguenet is offline
Registered Forum User
Big Twin
 
Posts: 1,411
Join Date: Aug 2002
Problem is back.
Managed to reset twice but this morning, nothing doing.
Does anybody know if there is a way to bypass?
Surely it is just verifying the key is ok and allowing the juice to flow.
I would doubt that it has the sophistication of a CAN comm with ECU?
Reply With Quote
  #6  
Old 15-Nov-2012, 02:35 PM
skidlids's Avatar
DSC Region Organiser skidlids skidlids is offline
MotoGP God
 
Posts: 18,165
Join Date: Apr 2002
Mood: Its ONLY a Bike Club
Phillipe it might just be the Ariel or the Ariel lead that picks up the transponder in the key, have you another one you can try or any one close by got one you could borrow


Checkout the Desmo Due Paddock on Facebook
Reply With Quote
  #7  
Old 27-Aug-2013, 03:30 AM
bikermok bikermok is offline
Registered Forum User
Newbie
 
Posts: 2
Join Date: Aug 2013
I have a 2002 ST4S and I had big problem with it's temper that the engine can start sometimes but sometimes not. I have to walk away having a coffee and most of the time when I come back , the engine starts untill even this could not work after the battery is empty out , recharged, and empty out.
I tool the bike to Ducati dealer and test it on computer, nothing abnormal was found.
They changed the relay and the sensors for me. Now, it's temper is a lot better. It does not start sometimes but after a few teimes of trun the key on and off, it starts. Seems like the problem is still there but just not as bad as before.
Reply With Quote
  #8  
Old 28-Aug-2013, 12:23 PM
stafford's Avatar
stafford stafford is offline
Registered Forum User
Bevel Head
Bikes: 888 Strada 888 Classic TT S2R1000 1000SS ST4S 900SSie M750 600SS
 
Posts: 91
Join Date: Jun 2006
Mood: Looking for speed
Have a chat with Anthony at Avanti Race Parts as he has some insight into the ST4S's failings and ways of curing them.
Reply With Quote
  #9  
Old 16-Nov-2013, 10:50 PM
ratchet's Avatar
ratchet ratchet is offline
Registered Forum User
Montjuic
 
Posts: 69
Join Date: Mar 2005
Mood: bring on the sun !
if worse when engine warm, may be crank sensor starting to break down,
hence ECU is not seeing engine turning over, and injecting fuel etc
problem is verifying if that is the culprit.
Reply With Quote
Reply
  
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector
Switch to Vertical postbit Use Vertical Postbit

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Recent Posts - Contact Us - DSC Home - Archive - Top
Powered by vBulletin 3.5.4 - Copyright © 2000 - 2018, Jelsoft Enterprises Ltd. - © Ducati Sporting Club - All times are GMT +1. The time now is 05:08 PM.