Ducati Sporting Club
Home Calendar Gallery Membership Online Shop DSC Blogs Extras
Go Back   Ducati Sporting Club > Model Specific - Discussion, Technical Problems and Help > STs
Reload this Page ST4s Cutting out
Forum Home Register FAQ Search Forum Recent Posts Mark Forums Read

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 20-Oct-2018, 11:23 AM
maxgain maxgain is offline
Registered Forum User
Newbie
Bikes: ST4s abs
 
Posts: 1
Join Date: Oct 2018
ST4s Cutting out

Hi, I wonder if someone could throw some light on issues I have been having with my ST4s. Back in 2016 I overhauled and serviced the bike including belt change. I changed the stock plugs for iridium ones and after a lot of reading on various forums, also replaced the plug leads for some Blue Magecore ones.



After, I had a problem whereby if the bike is revved, then the instant the revs drop at their lowest point on he rev counter, if its revved again, the bike cuts out. I researched a lot of info on iridium plugs re. gap settings before I replaced these and chose to change the gap from the pre-set to 1mm. I never used the bike much since the 2016 overhaul and have have just serviced it again including replacing belts and cleaning the plugs and still have the same issue. It worked fine before I did the work back in 2016 with the original plugs/wires. I just wish to get the bike right and dont wish it cutting out when I least need it..


Stu
Reply With Quote
  #2  
Old 22-Oct-2018, 09:02 AM
Iconic944ss's Avatar
DSC Member Iconic944ss Iconic944ss is offline
DSC Webteam
Webteam
WSB Hero
Bikes: 1993 - 944ss / Aprilia Falco / ST4S
 
Posts: 7,764
Join Date: Oct 2002
Hi Stu,

I'm wondering if you could have disturbed the ignition sensor on the LHS front of the bike?

Failing that, try undoing the changes you made, new components can be faulty from new, perhaps change one item at a time.

Good luck


Cheers - Frank
Reply With Quote
  #3  
Old 23-Oct-2018, 09:38 PM
antonye's Avatar
DSC Member antonye antonye is offline
Administrator
Webteam
MotoGP God
Bikes: 748S, HM1100S, DD-A
 
Posts: 12,739
Join Date: Feb 2002
Mood: Passion Killer
Did you gap the plugs correctly? The gap needs to be bigger than standard plugs! You may not be getting a good enough spark.

Gap for iridium plugs should be 0.9mm, compared to 0.6mm for standard.

HTH!


I'd rather die peacefully in my sleep like my Grandfather,
than screaming in terror like his passengers.- Jim Harkins

Ducati 748S | Ducati Hypermotard 1100S | 600-620SS DesmoDue Racebike #111 <-- Sold!! | Avanti Race Parts
Reply With Quote
Reply
  
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector
Switch to Vertical postbit Use Vertical Postbit

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Recent Posts - Contact Us - DSC Home - Archive - Top
Powered by vBulletin 3.5.4 - Copyright © 2000 - 2018, Jelsoft Enterprises Ltd. - © Ducati Sporting Club - All times are GMT +1. The time now is 11:36 AM.