Ducati Sporting Club UK
 
 
Thread Tools Search this Thread Display Modes
  #1  
Old 04-Feb-2024, 10:08
hawkati's Avatar
hawkati hawkati is offline
Registered Forum User
Mille
Bikes: ducati 996, hawkati, kawacati
 
Posts: 236
Join Date: Jun 2009
Mood: generally vile and mischevious
instruments/lights cut out then complete shut down

Many gnash - after 9 months of the bike behaving perfectly it decided to cut out completely the other day. First warning was the instruments & lights cutting out under hard acceleration (but all coming back on as soon as i hit pass switch) - gentle riding then didn't indicate any issues but then it completely cut out - full electrical failure.
The reason was obvious - the negative cable had simply sheared right off where the metal tang bends through 90 degrees. Simple to solve - bend remaining metal and drill hole, reattatch to battery. Ought to be good. Nope - as soon as ignition turns on then the instruments fuse blows and there's no power at all. I'm praying it's something like the instruments relay and i'll try it again with the display unplugged, but concerned that it's shorted out within the display unit itself.
Anyone experienced anything similar? I'm sure it's all earthed okay and i replaced the reg with an electrex item just over a year ago. Cheers!
Quote+Reply
  
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector
Switch to Vertical postbit Use Vertical Postbit

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Recent Posts - Contact Us - DSC Home - Archive - Top
Powered by vBulletin 3.5.4 - Copyright © 2000 - 2024, Jelsoft Enterprises Ltd. - © Ducati Sporting Club UK - All times are GMT +1. The time now is 14:40.